View Issue Details

IDProjectCategoryView StatusLast Update
0026665mantisbtcustom fieldspublic2021-03-07 18:28
ReporterHainKurt Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.23.0 
Target Version2.25.0Fixed in Version2.25.0 
Summary0026665: Custom fields with comma can't be used in Manage Config Columns page
Description

When we use a custom field like "Date (year, month, day)",

projectissues/manage_config_columns_page.php

page crashes if we want to use that column in csv/excel configuration...
probably it fails for others as well...

TagsNo tags attached.

Activities

dregad

dregad

2021-01-31 12:31

developer   ~0065052

The problem is confirmed, error is

APPLICATION ERROR 2601
Field "csv" contains invalid field "custom_Date (year".

@HainKurt, I would suggest as a workaround that you use a valid PHP identifier for your custom field's name - as is recommended in the documentation [1], and use language strings to display fancy characters such as commas.

dregad

dregad

2021-02-15 17:47

developer   ~0065131

PR https://github.com/mantisbt/mantisbt/pull/1739

Related Changesets

MantisBT: master 4d977638

2021-02-06 19:31:06

dregad

Details Diff
Custom Field names with commas (`,`) are forbidden

Until now, the custom fields management page allowed saving a Custom
Field with commas; attempting to use such a field in the Manage Columns
pages results in APPLICATION ERROR 2601 when trying to save the
configuration.

This commit prevents saving or updating a custom field if its name
contains a comma.

Fixes 0026665
Affected Issues
0026665
mod - core/constant_inc.php Diff File
mod - core/custom_field_api.php Diff File
mod - lang/strings_english.txt Diff File