View Issue Details

IDProjectCategoryView StatusLast Update
0027111mantisbtcustom fieldspublic2020-08-09 07:53
Reporterjackson03 Assigned Todregad  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version2.24.0 
Summary0027111: Change the status displayed in [My View]
Description

I want to change the task status displayed in [Assign to me (unresolved)] in [My View].

For example, if you have the following task status:
・New
・Feedback
・Acknowledged
・Confirmed
・Assigned
・Resolved
・Deployed
・Closed

Currently, tasks that are displayed in [Assign to me (unresolved)] are tasks with a status of "Confirmed".
When the task status is "Confirmed", I want to prevent it from being displayed to [Assign to me (unresolved)].

TagsNo tags attached.

Relationships

duplicate of 0007840 acknowledged Customizable 'my view' page 

Activities

dregad

dregad

2020-07-28 03:20

developer   ~0064189

Currently, tasks that are displayed in [Assign to me (unresolved)] are tasks with a status of "Confirmed".

This is incorrect. The box shows issues assigned to the current user, that have a status <= bug_resolved_status_threshold as defined in configuration.

When the task status is "Confirmed", I want to prevent it from being displayed to [Assign to me (unresolved)].

This can't be done without modifying MantisBT code (not supported). I suggest you unassign the Confirmed issues so they disappear from the box.

I'm resolving this as duplicate of 0007840 as it covers the same topic of customizing My View

jackson03

jackson03

2020-07-28 04:37

reporter   ~0064193

You have customized your status.
Although it was set to "confirmed" in the example, it is not "confirmed" in reality, so it is difficult to change the status immediately.

It is customized as follows.
The status set to 110 is displayed in [Assign to me (unresolved)].
Does the displayed number change depending on the assigned number?

$s_status_enum_string = '10:xxx,20:xxx,30:xxx,40:xxx,60:xxx,80:xxx,100:xxx,110:xxx,120:xxx,140:xxx,150:xxx,155: xxx,160:xxx,180:xxx,190:xxx';
dregad

dregad

2020-07-29 03:00

developer   ~0064199

I don't understand why you're reopening this issue, I already provided the answer in 0027111:0064189 :

This can't be done without modifying MantisBT code (not supported). I suggest you unassign the Confirmed issues so they disappear from the box.

If and when the feature in 0004632:0007840 gets implemented, then may be possible to achieve this customization without code.
The fact that you customized your status does not change anything to that.

Issue History

Date Modified Username Field Change
2020-07-27 23:45 jackson03 New Issue
2020-07-28 03:20 dregad Assigned To => dregad
2020-07-28 03:20 dregad Status new => resolved
2020-07-28 03:20 dregad Resolution open => duplicate
2020-07-28 03:20 dregad Note Added: 0064189
2020-07-28 03:20 dregad Relationship added duplicate of 0007840
2020-07-28 04:37 jackson03 Note Added: 0064193
2020-07-28 23:07 jackson03 Status resolved => feedback
2020-07-28 23:07 jackson03 Resolution duplicate => reopened
2020-07-29 03:00 dregad Status feedback => resolved
2020-07-29 03:00 dregad Resolution reopened => duplicate
2020-07-29 03:00 dregad Note Added: 0064199
2020-08-09 07:53 atrol Status resolved => closed