View Issue Details

IDProjectCategoryView StatusLast Update
0027584mantisbtdocumentationpublic2020-11-30 17:07
Reporterrajerrell Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027584: Out of the box Mantis does not display either a Dependancy or Relationship Graph
Description

After 2 solid weeks of trying to get a graph to display for either or both the dependency graph or the relationship graph I don't know where to turn.
Requirements
Issue 1 relates to issue 2 - graph that relationship
Issue 1 depends on 2 - graph that dependency.

WHY ISN'T THIS AN OUT-OF-THEBOX FUNCTIONALITY?????

Steps To Reproduce

InstalledGraphviz in any of the many ways known produces nothing.

  • Copied to the Plugins folder( there is no accompanying .php file with it and no instructions to build one)
  • Pip (python installation useless to php)
    • choco (results in a Python installation useless to Php)
      Win64.exe ( installs be there is no NETAO.EXE to point to in the latest version)
Additional Information

206-981-9023 CELL FOR ANYONE WILLING TO SAVE A LIFE AND HELP US UNDERSTAND HOW TO MAKE THIS WORK.

TagsNo tags attached.

Relationships

related to 0005037 closedgrangeway No more rel. graphs with PHP 4.3.10 and Win2K 

Activities

atrol

atrol

2020-11-23 15:18

developer   ~0064692

InstalledGraphviz in any of the many ways known produces nothing.

Are you able to us Graphviz in general, independant from Mantis?

If yes, did you configure Mantis, especially have you set $g_dot_tool and $g_neato_tool according Admin Guide ?
https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.relationship

rajerrell

rajerrell

2020-11-23 15:34

reporter   ~0064693

Last edited: 2020-11-24 12:34

@atrol

Thank you for the rapid response.
Graphviz is copied under the mantis\plugins folder

C:\xampp\htdocs\mantis\config\config_inc.php
(please note: there is no "neto.exe" in the current version of graphviz and I can't find any indication that even exists any longer. I did find some 2015 documentation that used the syntax shown below
$g_relationship_graph_enable = ON;
$g_dot_tool = 'dot.exe';
$g_neato_tool = 'dot.exe -Kneato';
$g_relationship_graph_max_depth = 4;
$g_relationship_graph_view_on_click = ON;

I can get a dependency graph now with the settings above but still get a broken image for the relationship graph.

Updated:
Putting these same setting into our production server worked.
Our current configuration on the production server is like this for anyone out there reading this.

  • We removed graphviz from the plugins folder.
  • We installed graphviz using the exe and it resides now in C:\Program Files\Graphviz 2.44.1
  • We set the PATH statement to point to include "C:\Program Files\Graphviz 2.44.1\bin" (including the BIN folder in the path)
  • VERY IMPORTANT: Open an ADMINISTRATOR command prompt and type dot -c ( this initializes the graph engine)

Open an issue and view the graphs.

  • Roger Jerrell (rjerrell@gmail.com)
dregad

dregad

2020-11-25 07:51

developer   ~0064699

@rajerrell based on your last post I assume that your problem is solved.

Thanks for sharing the solution, I will update the documentation to hopefully make this easier for other users.

I'm resolving this issue now, feel free to reopen if problem remains.

dregad

dregad

2020-11-25 12:35

developer   ~0064700

Updated docs
https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.relationship

atrol

atrol

2020-11-25 13:48

developer   ~0064701

@dregad I didn't try, but I am pretty sure there are other root causes for this issue.

First of all we have documented for $g_dot_tool and $g_neato_tool since quite long time that

this configuration option is not relevant for Windows

I would read this as: You can set it to whatever what you want, but it will not affect anything when running on Windows
This can't be true, as we execute commands which are configured by those options

$t_dot_tool = config_get_global( 'dot_tool' );
...
$t_graph = new Graph( 'workflow', $t_graph_attributes, $t_dot_tool );
...
$this->graphviz_tool = $p_tool;
...
$t_command = escapeshellcmd( $this->graphviz_tool . ' -T' . $p_format );` 

The default setting is
$g_dot_tool = '/usr/bin/dot';
which can't work on Windows as there is typically no folder /usr/bin

I suppose the following setting might work for @rajerrell on Windows without having the need to add the folder to %PATH%
$g_dot_tool = 'C:\Program Files\Graphviz 2.44.1\bin\dot.exe';
$g_neato_tool = 'C:\Program Files\Graphviz 2.44.1\bin\dot.exe -Kneato';
@rajerrell can you confirm it is also working this way?

dregad

dregad

2020-11-26 02:37

developer   ~0064705

Right, good point @atrol, your analysis makes sense.

Since I don't have time to setup a Windows environment for testing, I thought it might be useful to just add a warning in the docs; and it is because I did not confirm it, that I put it in conditional : The following post-installation steps may be required for proper operations

As for the this configuration option is not relevant for Windows note, looking at git history this seems to be a legacy and obsolete comment - in MantisBT master 629a6760 the WinGraphViz library was removed in favor of using the command-line tools directly; PHPDoc in config_defaults_inc.php was updated but not the Admin Guide.

If rajerrell can confirm, then we can further enhance the docs (and update also config_defaults_inc.php).

rajerrell

rajerrell

2020-11-30 17:07

reporter   ~0064725

I can confirm these settings work in a Windows 10 environment:

$g_dot_tool = 'C:\Program Files\Graphviz 2.44.1\bin\dot.exe';
$g_neato_tool = 'C:\Program Files\Graphviz 2.44.1\bin\dot.exe -Kneato';

Graphviz is installed per the settings above and there is no graphviz folder under Mantis plugins.
An environment entry in PATH is pointing to 'C:\Program Files\Graphviz 2.44.1\bin'

  • Roger Jerrell
    rjerrell@pentecom.com

Related Changesets

MantisBT: master 38e0dfd6

2020-11-25 08:16:59

dregad

Details Diff
Improve setup documentation for relationship graphs

Fixes 0027584
Affected Issues
0027584
mod - docbook/Admin_Guide/en-US/config/relationship.xml Diff File