View Issue Details

IDProjectCategoryView StatusLast Update
0027829mantisbttoolspublic2021-03-07 18:28
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027829: TravisCI: add PHP 8.0 to tests, and switch to bionic build environment
Description

Our test scripts need to run on PHP 8.0.

Also, Travis now offer Ubuntu bionic, so we should switch to that as standard build platform.

TagsPHP 8, TravisCI

Relationships

related to 0027830 closeddregad PHP 8.0 PostgreSQL builds fail due to deprecated pg_fieldsize() function 

Activities

dregad

dregad

2021-01-01 20:46

developer   ~0064910

Tweaking the build: sort PHP versions in descending order, so more recent ones are built first.

Related Changesets

MantisBT: master f16906f9

2021-01-01 19:36:18

dregad

Details Diff
TravisCI: enable PHP 8.0 builds

Allow pgsql to fail due to issue 0027830.

Fixes 0027829
Affected Issues
0027829, 0027830
mod - .travis.yml Diff File

MantisBT: master 67b3752b

2021-01-01 19:37:06

dregad

Details Diff
TravisCI: switch to bionic for build environment

Keep using xenial for legacy PHP versions (5.6 and 7.0) as they are not
supported on bionic.

Fixes 0027829
Affected Issues
0027829
mod - .travis.yml Diff File

MantisBT: master 0cb5e713

2021-01-01 19:45:37

dregad

Details Diff
TravisCI: sort PHP versions in descending order

This way, more recent versions are built first.

Issue 0027829
Affected Issues
0027829
mod - .travis.yml Diff File