View Issue Details

IDProjectCategoryView StatusLast Update
0027867mantisbtldappublic2021-03-04 17:34
Reporteramangion Assigned Todregad  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version20.04
Product Version2.24.4 
Summary0027867: error Ldap (APPLICATION ERROR # 1401)
Description

Hello I am integrating MantisBt 2.24.4 and it throws me the error:

---> (APPLICATION ERROR # 1401
Connection to LDAP server failed
Use the "Back" button on your web browser to go back to the previous page. There you can correct the problems that have been identified in this error notification or select another action. You can also click on an option in the menu bar to go directly to a new section.) <---

I have modified only the config_inc.php file with the following parameters:

$ g_ldap_server = 'ldap-name-gc.xxxxxx.xx';
$ g_ldap_port = '3268';
$ g_ldap_root_dn = 'DC = dom';
$ g_ldap_bind_dn = 'cn = username, cn = Users, dc = xXxX, dc = dom';
$ g_ldap_bind_passwd = 'XXXxxxXXX';

/ we don't want the users to be able to sign-up via mantis /

$ g_allow_signup = OFF; // Modified authentication_api.php file to avoid creating an account automatically if the user is in LDAP

$ g_use_ldap_email = ON;

/ we don't want false mantis lost password feature /

$ g_lost_password_feature = OFF;

$ g_log_level = LOG_EMAIL | LOG_EMAIL_RECIPIENT | LOG_DATABASE;
$ g_log_destination = 'file: /usr/share/ConTis/mantisbt.log'; * /

$ g_ldap_protocol_version = 3;
$ g_ldap_uid_field = 'sAMAccountName'; # Use 'sAMAccountName' for Active Directory - this is the name of the attribute used to search a user

I have checked in the logs, but it does not indicate any error:

2021-01-14 13:09 CET DB database_api.php: 313 db_query () array (
0 => 'SELECT config_id, user_id, project_id, type, value, access_reqd FROM mantis_config_table',
1 => '0.0004',
)
2021-01-14 13:09 CET DB database_api.php: 313 db_query () array (
0 => 'SELECT FROM mantis_user_table WHERE username = \' user@xxx.dom \ '',
1 => '0.0003',
)
2021-01-14 13:09 CET DB database_api.php: 313 db_query () array (
0 => 'SELECT
FROM mantis_user_table WHERE username = \' user@xxx.dom \ '',
1 => '0.0002',

if you could guide me, thanks

TagsNo tags attached.

Activities

amangion

amangion

2021-01-14 07:18

reporter  

11.PNG (18,312 bytes)   
11.PNG (18,312 bytes)   
dregad

dregad

2021-01-14 16:16

developer   ~0064980

You should set $g_log_level = LOG_LDAP; and check the output of your Mantis log.

Possibly the problem is caused by

$ g_ldap_server = 'ldap-name-gc.xxxxxx.xx';
$ g_ldap_port = '3268';

$g_ldap_port is deprecated; as per documentation, $g_ldap_server must be a full LDAP URI (ldap[s]://hostname:port)

atrol

atrol

2021-02-20 12:20

developer   ~0065144

amangion,

You did not provide any feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.