Inability to Add Plugins under a Bitnami Appliance

General discussion about MantisBT Plugins

Moderators: Developer, Contributor

Post Reply
dcmarti1
Posts: 3
Joined: 25 Oct 2020, 00:37

Inability to Add Plugins under a Bitnami Appliance

Post by dcmarti1 »

I downloaded the Bitnami 2.24.3 appliance for Linux. It successfully installed. I created a project, added the General categories, and even added a custom date field. 4 records added and I can query and update.

I downloaded the traceability-master.zip file, un-zipped it, and moved the dir to:

~/mantis-2.24.3-0/apps/mantis/htdocs/plugins

I noticed the perms were NOT the same as the other 3, so I did a chmod 755 on it. I stopped the MySQL and Apache servers, re-logged into Mantis, and went to Manage Plugins. They did NOT appear the Available Plugins section. I tried another plugin, did the same chmod, stopped the servers, and it does not appear either.

Is anyone aware if the ability to add new plugins is disabled in the appliance? I found other plugin posts on other Bitnami apps but NOT Mantis.

Thank you from a minimally qualified administrator.
mantis.png
mantis.png (135.3 KiB) Viewed 2166 times
atrol
Site Admin
Posts: 7864
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Inability to Add Plugins under a Bitnami Appliance

Post by atrol »

According README you have to use branch mantisbt_2_3_X
Did you download the right version?
https://github.com/mantisbt-plugins/tra ... isbt_2_3_X
Please use Search before posting and read the Manual
dcmarti1
Posts: 3
Joined: 25 Oct 2020, 00:37

Re: Inability to Add Plugins under a Bitnami Appliance

Post by dcmarti1 »

It is a version greater than 2.3.X. I think it's something in the Bitnami structure. If I had just a regular install it would probably work. I am just going to forget about plugins and (try to) learn to administer a basic Mantis.

Thank you.
atrol
Site Admin
Posts: 7864
Joined: 26 Mar 2008, 21:37
Location: Germany

Re: Inability to Add Plugins under a Bitnami Appliance

Post by atrol »

Seems you did not understand my question.

I suppose you did not download the right version of the plugin.
If you downloaded based on master branch, you downloaded the version that can be used with Mantis 1.2.x but not 2.x.x.
Please use Search before posting and read the Manual
dcmarti1
Posts: 3
Joined: 25 Oct 2020, 00:37

Re: Inability to Add Plugins under a Bitnami Appliance

Post by dcmarti1 »

I just re-downloaded the plugin and the zip file did have 2_3_x in the name. It failed again. I should learn to just stick with base systems.
cas
Posts: 935
Joined: 11 Mar 2006, 16:08
Contact:

Re: Inability to Add Plugins under a Bitnami Appliance

Post by cas »

Bitnami should be able to handle this so you should raise the question on their end.
If not possible, you should ask yourself if you really need (the limitations of ) Bitnami.
Post Reply